Narcoleptic Pasta Manufacturer
Wondering what’s next for npm?Check out our public roadmap! »

vdt-loader

1.5.1 • Public • Published

vdt loader for webpack

Installation

npm install vdt-loader --save-dev

Usage

require('vdt?noWith!./file.vdt');

Alternately, set this in config file.

For webpack@1.0

module: {
    loaders: [
        test: /\.vdt$/,
        loader: 'vdt-loader?noWith&delimiters={{}}'
    ]
}

For webpack@2.0/3.0

module: {
    rules: [
        {
            test: /\.vdt$/,
            use: [
                {
                    loader: 'vdt-loader',
                    options: {
                        noWith: true,
                        delimiters: ['{{', '}}']
                    }
                }
            ]
        }
    ]
}

Querystring

Vdt options

You can also pass querystring like below

'vdt-loader?options=' + encodeURIComponent(JSON.stringify({
    noWith: true,
    delimiters: ['{{', '}}']
}))

Notice

  1. v1.4.2 之后默认全部导出为es6模块 , 不再支持导出commonjs模块

Keywords

none

Install

npm i vdt-loader

DownloadsWeekly Downloads

27

Version

1.5.1

License

ISC

Unpacked Size

4.51 kB

Total Files

4

Last publish

Collaborators

  • avatar
  • avatar
  • avatar
  • avatar
  • avatar
  • avatar