validator-extensions

    1.0.0 • Public • Published

    validator-extensions

    validator.js is intentionally careful in what it includes.

    This library extends validator.js with a variety of useful ancillary validations.

    Criteria are:

    • general purpose
    • not included in recent versions of validator.js

    To Use

    Pass a validator instance to this library:

    "use strict";
     
    const validatorJS = require("validator");
    require("validator-extensions")(validatorJS);

    Testing

    To run tests, just $ npm i && npm test.

    Development assumes node >= 4.0 (or earlier versions with --harmony flags), but the functions themselves should work in any modern JS environment.

    Contributing

    Please see CONTRIBUTING.md.

    License

    MIT

    Install

    npm i validator-extensions

    DownloadsWeekly Downloads

    2

    Version

    1.0.0

    License

    MIT

    Last publish

    Collaborators

    • avatar