Miss any of our Open RFC calls?Watch the recordings here! »

sublime-linter

0.5.1 • Public • Published

sublime-linter

The MIT License GitHub CircleCI David

Linter for Sublime Text packages, supporting completions, snippets, build tools, syntax definitions and many more.

Installation

Install sublime-linter dependency for your Sublime Text package

yarn add sublime-linter --dev || npm install sublime-linter -D

Alternatively, you can install sublime-linter globally for use as a CLI tool

yarn global add sublime-linter || npm install -g sublime-linter

Usage

Create a package manifest for your Sublime Text package and mark it as private

Example:

{
  "name": "my-sublime-package",
  "version": "0.0.0",
  "private": true,
  "license": "MIT",
  "author": "your-name",
  "devDependencies": {
    "sublime-linter": "^0.4.0"
  },
  "scripts": {
    "test": "sublime-linter"
  }
}

License

This work is licensed under The MIT License

Donate

You are welcome to support this project using Flattr or Bitcoin 17CXJuPsmhuTzFV2k4RKYwpEHVjskJktRd

Install

npm i sublime-linter

DownloadsWeekly Downloads

0

Version

0.5.1

License

MIT

Unpacked Size

6.87 kB

Total Files

7

Last publish

Collaborators

  • avatar