Have ideas to improve npm?Join in the discussion! »

    roughly

    0.0.3 • Public • Published

    Roughly.js

    Approximate/Fuzzy variable stuff

    API Concept

    npm install roughly

     
    const Roughly = require("roughly")
     
    const x = new Roughly.number({ greaterThan: 10, lessThan: 20 })
     
    x.lessThan(20) // true
    x.lessThan(21) // true
    x.lt(21) // true
     
    x.greaterThan(15) // undefined
    x.gt(10) // true
     
    const y = new Roughly.number({ greaterThan: 3 })
     
    y.gt(2) // true
    y.gt(3.1) // undefined
    y.lt(3.1) // undefined
    y.lt(2) // false
     

    Install

    npm i roughly

    DownloadsWeekly Downloads

    2

    Version

    0.0.3

    License

    MIT

    Last publish

    Collaborators

    • avatar