Wondering what’s next for npm?Check out our public roadmap! »

postcss-selector-not

4.0.1 • Public • Published

postcss-selector-not CSS Standard Status Build Status

PostCSS plugin to transform :not() W3C CSS level 4 pseudo class to :not() CSS level 3 selectors

http://dev.w3.org/csswg/selectors-4/#negation

'Can I use' table

Installation

$ npm install postcss-selector-not

Usage

var postcss = require("postcss")

var output = postcss()
  .use(require("postcss-selector-not"))
  .process(require("fs").readFileSync("input.css", "utf8"))
  .css

Using this input.css:

p:not(:first-child, .special) {
  color: red;
}

you will get:

p:not(:first-child):not(.special) {
  color: red;
}

Changelog

License

Install

npm i postcss-selector-not

DownloadsWeekly Downloads

3,577,393

Version

4.0.1

License

MIT

Unpacked Size

6.54 kB

Total Files

5

Last publish

Collaborators

  • avatar
  • avatar
  • avatar