Miss any of our Open RFC calls?Watch the recordings here! »

polyfer

0.1.0 • Public • Published

Polyfer NPM version Build Status Dependency Status

Post-processor for Polymer CSS polyfills

Install

$ npm install --save polyfer

In a case that you are a task manager lover, please try gulp-polyfer or grunt-polyfer and have fun :)

Usage

Module

var polyfer = require('polyfer');
 
polyfer('::content p { color: blue; }');
// => polyfill-next-selector { content: 'p' } ::content p { color: blue; }
 
polyfer('x-element ::content p {...}');
// => polyfill-next-selector {...} x-element ::content
 
polyfer(':scoped x-element p { color: blue; }');
// => polyfill-rule { content: 'x-element p'; color: blue; }
 
polyfer(':unscoped x-element p');
// => polyfill-unscoped-rule {...}
 
// since some preprocessors do not support /deep/ selectors
polyfer('body :deep a { outline: 1; }');
// => body /deep/ a { outline: 1; }

See examples comparing fixture.css(before) with expected.css(after).

Client

$ npm install --global polyfer
$ polyfer input.css
$ polyfer input.css > output.css
$ polyfer --help

Release notes

  • 0.1.0 - refactory, bug fixes and /deep/ selectors
  • 0.0.x - first releases

Roadmap

  • 0.2.0 - enable and disable specific polyfills processing

Contribute

Keep in mind that all tasks run through Grunt.js.

git clone https://github.com/heldr/polyfer.git
cd polyfer
npm install
grunt watch

License

MIT © Helder Santana

Install

npm i polyfer

DownloadsWeekly Downloads

1

Version

0.1.0

License

MIT

Last publish

Collaborators

  • avatar