Miss any of our Open RFC calls?Watch the recordings here! »

outdated-pod-regex

1.0.0 • Public • Published

outdated-pod-regex

NPM version Build Status Coverage Status devDependency Status

Create a regular expression object that matches the outdated Pod list generated with pod outdated command

const stdout = `
- CrittercismSDK 5.3.0 -> 5.3.0 (latest version 5.4.0)
- GCDWebServer 3.2.5 -> 3.2.7 (latest version 3.2.7)
`;
 
stdout.match(outdatedPodRegex());
//=> ['- CrittercismSDK 5.3.0 -> 5.3.0 (latest version 5.4.0)', '- GCDWebServer 3.2.5 -> 3.2.7 (latest version 3.2.7)']

Installation

package managers

npm

npm install outdated-pod-regex

bower

bower install outdated-pod-regex

Standalone

Download the script file directly.

API

outdatedPodRegex()

Return: RegExp instance with g and m flags

const stdout = `
- CrittercismSDK 5.3.0 -> 5.3.0 (latest version 5.4.0)
- GCDWebServer 3.2.5 -> 3.2.7 (latest version 3.2.7)
`;
 
const regex = outdatedPodRegex();
 
regex.exec(stdout);
//=> ['- CrittercismSDK 5.3.0 -> 5.3.0 (latest version 5.4.0)', 'CrittercismSDK', '5.3.0', '5.3.0', '5.4.0']
 
regex.exec(stdout);
//=> ['- GCDWebServer 3.2.5 -> 3.2.7 (latest version 3.2.7)', 'GCDWebServer', '3.2.5', '3.2.7', '3.2.7']
 
regex.exec(stdout);
//=> null

License

The Unlicense

Install

npm i outdated-pod-regex

DownloadsWeekly Downloads

0

Version

1.0.0

License

Unlicense

Last publish

Collaborators

  • avatar