Have ideas to improve npm?Join in the discussion! »

    maxrow

    1.1.3 • Public • Published

    MaxRow

    MaxRow is a library to help you to create a editable area, which limit users to input no more than exact rows.

    Installation

    Option 1: npm
    If you prefer the node package manager, feel free to use it.
    Keep in mind that like with bower non-crucial files will be ignored (see above).

    npm install maxrow

    Option 2: Bower

    Include the core library in your HTML file:

    <script src="../lib/maxrow.min.js"></script>

    Usage

    import maxRow from "maxrow";
    
    // init controller
    let word = new maxRow({selector:"#word",row:3})
    
    // create a sprite
    word.setText('Hello world!');

    Parameters

    • selector: #id DOM selector, default: body
    • row: (number) max rows limited, default: 3
    • dialog: (function) popup msg dialog, default: alert

    Browser Support

    MaxRow aims to support all major browsers even in older versions:
    Firefox 26+, Chrome 30+, Safari 5.1+, Opera 10+, IE 9+

    About the Author

    I am a creative coder based in Xiamen, China.

    Learn more on my website or Follow me on Weibo

    License

    MaxRow is dual licensed under the MIT.
    For more information click here.

    Install

    npm i maxrow

    DownloadsWeekly Downloads

    0

    Version

    1.1.3

    License

    MIT

    Unpacked Size

    11.5 kB

    Total Files

    8

    Last publish

    Collaborators

    • avatar