Need private packages and team management tools?Check out npm Teams »

This package has been deprecated

Author message:

deprecated in favour of http://npmjs.org/mattophobia

mattophobia-says

0.3.1 • Public • Published

Mattophobia Says Build Status

Inside the Mind of Mattophobia as JS Bindings.

Python Fork

There is a python fork of this project available here.

Documentation

  • MattSays
    • new MattSays([swears], [ings], [standalone], [merge])
    • .generateSentence([min], [max]) --> string

new MattSays([swears], [ings], [standalone], [merge])

Param Type Description
[swears] string[] List of Swear Words
[ings] string[] List of -Ing Words
[standalone] string[] List of Standalone Words/ Phrases
[merge] boolean Merge with default arrays or just overwrite

mattSays.generate([min], [max]) --> string

Generate a random Mattophobia Style Sentence

Kind: instance method of MattSays

Param Type Default Description
[min] number 4 Minimum number of words
[max] number 18 Maximum number of words

Install

npm i mattophobia-says

DownloadsWeekly Downloads

0

Version

0.3.1

License

ISC

Unpacked Size

13.7 kB

Total Files

7

Last publish

Collaborators

  • avatar