Have ideas to improve npm?Join in the discussion! »

    list_requires_multi

    1.0.2 • Public • Published

    list_requires_multi

    List the libraries required by some Javascript code by parsing it

    Install

    npm install list_requires_multi
    

    Usage

    var list_requires_multi = require('list_requires_multi');
     
    var code = "a=require('foo'); b=require('bar')";
    console.log(list_requires_multi(code), ['require']);
    // will output {'require': ['foo', 'bar']}

    License

    MIT

    Credits

    By Geza Kovacs

    Install

    npm i list_requires_multi

    DownloadsWeekly Downloads

    4

    Version

    1.0.2

    License

    MIT

    Last publish

    Collaborators

    • avatar