Miss any of our Open RFC calls?Watch the recordings here! »

lasso-istanbul-instrument-transform

2.0.1 • Public • Published

lasso-istanbul-instrument-transform

Lasso.js transform that uses Istanbul to instrument ES6 code to ES5 for code coverage.

Prerequisites

This transform requires Lasso v2+

Installation

npm install lasso-istanbul-instrument-transform --save-dev

Usage

require('lasso').configure({
    require: {
        transforms: [
            {
                transform: 'lasso-istanbul-instrument-transform',
                config: {
                    extensions: ['.js', '.es6'] // Enabled file extensions. Default: ['.js', '.es6']
                }
            }
        ]
    }
});

Install

npm i lasso-istanbul-instrument-transform

DownloadsWeekly Downloads

90

Version

2.0.1

License

ISC

Unpacked Size

5.7 kB

Total Files

8

Last publish

Collaborators

  • avatar