Narcissistic Passion Minified
    Have ideas to improve npm?Join in the discussion! »

    gulp-pug-3

    1.2.2 • Public • Published

    Gulp Pug 3

    Build Status Dependency Status devDependencies Status Maintainability Snyk Vulnerabilities for GitHub Repo npm NPM Version contributions welcome node-current

    Compiles your pug templates into 'html' or 'js' easily and always uses the latest stable version of Pug Template Engine.

    Install

    npm install --save-dev gulp-pug-3

    Api

    In addition to Pug's API: client, extension and locals options are available.

    Example

    const pug = require('gulp-pug-3');
    
    gulp.task('build', () =>
        gulp.src('public/**/*.pug')
            .pipe(
                pug({ 
                    // Your options.
                })
            )
            .pipe(gulp.dest('dist'));
    );
    
    gulp.task('build:X', () => 
        gulp.src('public/**/*.pug')
            .pipe(
                pug({
                       locals: { dir: 'rtl', lang: 'es' },
                    extension: 'htm',
                    // Pug API default opts...
                      basedir: `${__dirname}/public`
                })
            )
            .pipe(gulp.dest('dist'));
    )

    Troubleshooting

    When you encounter a problem, please open an issue. I would be glad to help you to find a solution if possible.

    Author

    Github: @orcunsaltik

    License

    See the LICENSE file for license rights and limitations (MIT).

    Install

    npm i gulp-pug-3

    DownloadsWeekly Downloads

    117

    Version

    1.2.2

    License

    MIT

    Unpacked Size

    7.3 kB

    Total Files

    9

    Last publish

    Collaborators

    • avatar