npm

Need private packages and team management tools?Check out npm Orgs. »

This package has been deprecated

Author message:

This package is built around dependencies which are no longer being maintained. No further updates are planned.

flat-raml

1.2.3 • Public • Published

node-flat-raml

Flatten a multi-file RAML document into a single RAML file

Flattening a RAML document into a single file

srcFile = 'spec.raml'
dstFile = 'flat.raml'
flattener = require 'flat-raml' 
flattener.flatten srcFile dstFile
  .then (outFile) -> console.log(outFile"written")
  .catch (error) -> "error flattening RAML doc:"error"\nstack:\n"error.stack

Parsing a RAML document into a serialized string

srcFile = 'spec.raml'
flattener = require 'flat-raml' 
flattener.asString srcFile
  .then (serialized) -> console.log(srcFile"read. Serialized content:\n"serialized)
  .catch (error) -> "error reading RAML doc:"error"\nstack:\n"error.stack

Keywords

install

npm i flat-raml

Downloadsweekly downloads

44

version

1.2.3

license

none

homepage

github.com

repository

Gitgithub

last publish

collaborators

  • avatar
Report a vulnerability