Negatively Proportional Model
    Wondering what’s next for npm?Check out our public roadmap! »

    eslint-plugin-saxo

    1.8.4 • Public • Published

    ESLint-Plugin-Saxo

    ESLint rules that have been developed at Saxo to enforce a range of project specific and general standards.

    Installation

    Install ESLint either locally or globally.

    $ npm install eslint
    

    If you installed ESLint globally, you have to install the plugin globally too. Otherwise, install it locally.

    $ npm install eslint-plugin-saxo
    

    Configuration

    Add a plugins section and specify eslint-plugin-saxo as a plugin.

    Then, enable all of the rules that you would like to use.

    Recommended configuration

    This plugin exports a recommended configuration that enforces all the rules. You can configure the plugin as follows:

    {
      "plugins": ["saxo"],
      "extends": ["plugin:saxo/recommended"]
    }

    List of provided rules

    Rules are divided into categories for your convenience. All rules are off by default, unless you use one of the plugin's configurations which turn all relevant rules on.

    Stylistic Issues

    These rules are purely matters of style and are quite subjective.

    Contributing

    Contributions are always welcome!.

    License

    eslint-plugin-saxo is licensed under the MIT License.

    Install

    npm i eslint-plugin-saxo

    DownloadsWeekly Downloads

    4

    Version

    1.8.4

    License

    MIT

    Unpacked Size

    42.7 kB

    Total Files

    22

    Last publish

    Collaborators

    • avatar
    • avatar
    • avatar