Miss any of our Open RFC calls?Watch the recordings here! »

eslint-plugin-react-i18n

1.0.3 • Public • Published

eslint-plugin-react-i18n

Build Status npm version

ESLint rules to help enforce i18n in react.

Primarily supports i18next, but happy to accept PRs to add support for other popular react i18n frameworks.

Installation

You'll first need to install ESLint:

$ npm i eslint --save-dev

Next, install eslint-plugin-react-i18n:

$ npm install eslint-plugin-react-i18n --save-dev

Note: If you installed ESLint globally (using the -g flag) then you must also install eslint-plugin-react-i18n globally.

Usage

Add react-i18n to the plugins section of your .eslintrc configuration file. You can omit the eslint-plugin- prefix:

{
  "plugins": ["react-i18n"]
}

Then configure the rules you want to use under the rules section.

{
  "rules": {
    "react-i18n/rule-name": "error"
  }
}

You can also use the recommended config instead

{
  "extends": ["plugin:react-i18n/recommended"]
}

Supported Rules

Install

npm i eslint-plugin-react-i18n

DownloadsWeekly Downloads

1,550

Version

1.0.3

License

MIT

Unpacked Size

21.4 kB

Total Files

14

Last publish

Collaborators

  • avatar
  • avatar