Nocturnal Prancing Mosquito

    eslint-plugin-quick-prettier

    0.0.29 • Public • Published

    eslint-plugin-quick-prettier

    eslint-plugin-quick-prettier package is meant to be used instead of eslint-plugin-prettier to quickly fix formatting problems (in editor or command line with eslint --fix) without raising any warning during editing.

    eslint-plugin-prettier can be slow for very big projects. eslint-plugin-prettier raises warnings and errors for formatting.

    installation

    Install the package with

    npm install --save-dev eslint-plugin-quick-prettier

    Enable the plugin in your .eslintrc using the recommended configuration

    {
      "extends": ["plugin:quick-prettier/recommended"]
    }

    Or enable just plugin in your .eslintrc

    {
      "plugins": ["quick-prettier"],
      "rules": {
        "quick-prettier/prettier": 1
      }
    }

    To run some native fixable eslint rules only in fix mode, without raising waenings, in .eslintrc

    {
      "plugins": ["quick-prettier"],
      "rules": {
        "quick-prettier/prettier": [
          1,
          {
            // Prettifies package.json files
            "prettify-package-json": true,
            "rules": {
              // eslint native rules to run only in --fix mode
              "padding-line-between-statements": [
                1,
                {
                  "blankLine": "always",
                  "next": "import",
                  "prev": "let"
                }
              ],
              "...another-rule": [1, "..."]
            }
          }
        ]
      }
    }

    Install

    npm i eslint-plugin-quick-prettier

    DownloadsWeekly Downloads

    469

    Version

    0.0.29

    License

    MIT

    Unpacked Size

    25.3 kB

    Total Files

    8

    Last publish

    Collaborators

    • avatar