Miss any of our Open RFC calls?Watch the recordings here! »

eslint-config-skyscanner

8.1.0 • Public • Published

eslint-config-skyscanner

Build Status npm version

This package includes the shareable ESLint configuration used by Skyscanner.

Installation

npm install --save-dev eslint-config-skyscanner

Add "extends": "skyscanner" to your .eslintrc.

React

eslint-config-skyscanner will try to detect automatically the version of React installed.

If your project doesn't use it or it is not installed in the same package.json as eslint-config-skyscanner, it must be manually set in .eslintrc:

"settings": {
  "react": {
    "version": "16.4"
  }
}

Changelog

View our up-to-date changelog.

Install

npm i eslint-config-skyscanner

DownloadsWeekly Downloads

354

Version

8.1.0

License

Apache-2.0

Unpacked Size

49.8 kB

Total Files

27

Last publish

Collaborators

  • avatar
  • avatar
  • avatar
  • avatar
  • avatar
  • avatar
  • avatar
  • avatar