Next Perpendicular Moonlanding

    This package has been deprecated

    Author message:

    this package is not maintained anymore

    eslint-config-graubnla

    3.0.0 • Public • Published

    eslint-config-graubnla

    npm

    This is basicly a fork of eslint-config-airbnb with some personal tweaks.

    This config is using ESLint 2

    Usage

    This package exports three ESLint configurations.

    eslint-config-graubnla

    Default ESLint rules, including ES2015 and react. It requires eslint and eslint-plugin-react.

    1. npm install -D eslint-config-graubnla eslint-plugin-react eslint
    2. Add "extends": "graubnla" to your .eslintrc

    eslint-config-graubnla/base

    Lints ES6+ but does not lint React. Requires eslint.

    1. npm insatll -D eslint-config-graubnla eslint
    2. Add "extends": "graubnla/base" to your .eslintrc

    eslint-config-graubnla/legacy

    Lints ES5 and below. Only requires eslint.

    1. npm insatll -D eslint-config-graubnla eslint
    2. Add "extends": "graubnla/base" to your .eslintrc

    Install

    npm i eslint-config-graubnla

    DownloadsWeekly Downloads

    2

    Version

    3.0.0

    License

    MIT

    Last publish

    Collaborators

    • avatar