Get unlimited public & private packages + team-based management with npm Teams.Learn more »

cssb-max-descendants

0.0.1-alpha • Public • Published

cssb-max-descendants

A css-bouncer plugin for checking against the maximum length of descendants.

Usage

var cssb = require('css-bouncer');
var linter = cssb();
linter.rule('cssb-max-descendants');
var result = linter.lint('div .class #id > ul > li.class {}');
console.log(result);
//[ { location: '1:1',
//    level: 'error',
//    message: 'Descendent length for selector is too long! 5 is more than the maximum of 3.' } ]

Install

npm i cssb-max-descendants

DownloadsWeekly Downloads

2

Version

0.0.1-alpha

License

MIT

Last publish

Collaborators

  • avatar