Have ideas to improve npm?Join in the discussion! »

crashpad

1.2.4 • Public • Published

Crashpad

Express middleware for Boom errors

NPM version Build Status MIT License

Usage

Install this middleware and stop explicitly responding with errors from your application code!

npm install crashpad
var crashpad = require('crashpad');
var Boom = require('boom');
 
app.get('/error', function(req, res, next) {
  throw Boom.expectationFailed();
});
 
app.use(crashpad());

Crashpad will handle:

Right now Crashpad just sends back JSON payloads. Eventually, we'll have support for fancy rendered error pages! If you need something like that now, check out express-error-handler.

Contributing

Please follow our Code of Conduct when contributing to this project.

$ git clone https://github.com/goodeggs/crashpad && cd crashpad
$ npm install
$ npm test

Keywords

Install

npm i crashpad

DownloadsWeekly Downloads

8

Version

1.2.4

License

MIT

Last publish

Collaborators

  • avatar
  • avatar