npm

Need private packages and team management tools?Check out npm Orgs. »

This package has been deprecated

Author message:

This module is no longer actively maintained.

catbox-mongodb

4.2.1 • Public • Published

catbox-mongodb

MongoDB adapter for catbox

Build Status catbox-mongodb

Lead Maintainer: Marcus Poehls

catbox-mongodb serializes values to BSON using MongoDB driver, therefore following data types are supported for this adapter: Object, Array, Number, String, Date, RegExp.

Installation

The lastest catbox-mongodb version 4.x works only with hapi v17

Install catbox-mongodb via NPM. Remember that catbox-mongodb requires its parent module catbox:

npm install catbox catbox-mongodb

Do you use hapi v16 or lower? Install catbox-mongodb version 3.x with a compatible version of catbox:

# for hapi v16 (or lower)
npm install catbox@9 catbox-mongodb@3

Options

catbox-mongodb accepts the following options:

  • uri - the MongoDB URI, defaults to 'mongodb://127.0.0.1:27017/?maxPoolSize=5'
  • partition - the MongoDB database for cached items

Usage

Sample catbox cache initialization :

const Catbox = require('catbox');
 
const cache = new Catbox.Client(require('catbox-mongodb'), {
    uri: 'your-mongodb-uri', // Defaults to 'mongodb://127.0.0.1:27017/?maxPoolSize=5' if not provided
    partition: 'cache'
})

Or configure your hapi server to use catbox-mongodb as the caching strategy (code snippet uses hapi v17):

const Hapi = require('hapi')
const CatboxMongoDB = require('catbox-mongodb')
 
const server = new Hapi.Server({
    cache : [{
        name      : 'mongoDbCache',
        engine    : CatboxMongoDB,
        uri       : 'your-mongodb-uri', // Defaults to 'mongodb://127.0.0.1:27017/?maxPoolSize=5' if not provided
        partition : 'cache'
    }]
});

install

npm i catbox-mongodb

Downloadsweekly downloads

148

version

4.2.1

license

BSD-3-Clause

homepage

github.com

repository

Gitgithub

last publish

collaborators

  • avatar
Report a vulnerability