Have ideas to improve npm?Join in the discussion! »

    bahai-autocorrect

    2.0.1 • Public • Published

    Bahai-autocorrect

    Simple replace script to correct most common Baha'i terms as UTF-8 in Text or HTML.

    Install the interface module into your node project with:

    npm install --save bahai-autocorrect
    

    Functionality

    const BahaiAutocorrect = require('bahai-autocorrect');
    let str = 'Haji Mirza Haydar-Ali'
    let bahaiAutocorrect = new BahaiAutocorrect(str).correct()
    let fixedStr = bahaiAutocorrect.toString()

    Underlined transliterations

    By default, this library outputs underlined transliterations (ch, dh, gh, kh, sh, th, zh) as html with <u> tags, e.g. "Síyáh-<u>Ch</u>ál".

    If you wish to use underscore notation, (e.g. "C_hál", you can run BahaiAutocorrect.stripUnderlines(). Note that in this case the underscores go between the letters, not before them.

    Keywords

    Install

    npm i bahai-autocorrect

    DownloadsWeekly Downloads

    2

    Version

    2.0.1

    License

    ISC

    Unpacked Size

    25.1 kB

    Total Files

    3

    Last publish

    Collaborators

    • avatar