Have ideas to improve npm?Join in the discussion! »

babel-plugin-greed

0.2.1 • Public • Published

Babel-Plugin-Greed

Babel Plugin for statically transforming data dependencies

This module should be used along within your projects if you are using greed. It ensures that data is available before your UI renders, preventing Waterfall pit.

Installation

npm install babel-plugin-greed

Usage

VIA .babelrc (Recommended)

{
  "plugins": ["babel-plugin-greed"]
}

Via CLI

babel --plugins babel-plugin-greed

Via Node API

require("babel-core").transform("code", {
  plugins: [require("babel-plugin-greed")]
});

License

MIT

Install

npm i babel-plugin-greed

DownloadsWeekly Downloads

3

Version

0.2.1

License

MIT

Last publish

Collaborators

  • avatar