atma-loader-less

    1.1.5 • Public • Published

    Less Compiler (Atma Plugin)

    Build Status

    The Plugin extends:

    How to use
    Embed into the Project
    • atma plugin install atma-loader-less

      This adds atma-loader-less npm dependency and the package.json would look like:

      {
          "dependency": {
              "atma-loader-less"
          },
          "atma": {
              "plugins": [
                  "atma-loader-less"
              ],
              "settings": {
                  "less_loader": {
                      "extension": "less"
                  }
              }
          }
      }
    • That's all. Now, you are ready to use 'dynamic stylesheets' in your project

    Quick Try
    • install atma: $ npm install atma -g

    • install plugin: $ atma plugin install atma-loader-less

    • add test.html to the directory

      <!DOCTYPE html>
      <link href='test.less' rel='stylesheet' />
    • add test.less

      @color: green;
      body { background: @color; }
    • start the server: $ atma server

    • open the browser: http://localhost:5777/test.html


    (c) MIT License - Atma.js Project

    Keywords

    none

    Install

    npm i atma-loader-less

    DownloadsWeekly Downloads

    33

    Version

    1.1.5

    License

    MIT

    Unpacked Size

    5.57 kB

    Total Files

    4

    Last publish

    Collaborators

    • avatar