apm-ui

    1.1.4 • Public • Published

    APM UI

    基于Regular-UI@0.1.8进行定制,初衷是希望在保持一贯轻量、简洁、高效等特性的同时,使组件更丰富,功能更强大。

    初衷

    • 组件功能不满足需求
    • 组件样式不满足需求
    • 组件交互不满足需求
    • 组件缺失

    以上,为了更好的管理以及维护组件,于是有了这个项目。

    特点

    • 轻量、简洁、高效
    • 基于Regularjs的组件库
    • 包含20多个CSS组件和30多个JS组件,可以快速构建内容丰富、功能复杂的页面,大幅提升开发效率。

    浏览器支持

    Chrome Firefox IE Safari Opera
    Latest ✔ Latest ✔ IE8+ Latest ✔ Latest ✔

    环境支持

    • Node Version >= 4.4.7 (Node版本)
    • NPM Version >= 3.8.6 (Node包管理)
    • Gulp Version >= 3.9.0

    安装运行

    贡献组件

    git clone {url}     # 克隆仓库
    npm install         # 在环境支持支持下,本地安装依赖库
    npm start           # 进入开发状态
    

    地址栏输入http://127.0.0.1:9999即可访问本地demo。

    使用组件

    npm install --save-dev apm-ui@1.0.0
    

    结构目录

    ├── README.md
    ├── dist
    ├── doc
    ├── doc-src
    ├── gulp
    │   ├── build.js
    │   └── dev.js
    ├── gulpfile.js
    ├── node_modules
    ├── package.json
    ├── src
    │   ├── js
    │   └── mcss
    ├── structure.js
    └── webpack.config.js
    

    问题汇总

    • npm install安装gulp-sass阻塞

      1. 切换到淘宝源,然后进行安装
      2. 注释掉gulp-sass进行npm install安装
      3. 2成功以后,撤销注释进行gulp-sass即可
    • gulp运行报Cannot find module 'jshint/src/cli'错误提示 在package.json中添加jshint依赖,然后npm install便可。

    更改日志

    1.0.0

    1. 基于regular-ui的诸多修改和完善
      • 构建流程
      • 文档规范

    1.1.0

    1. 网络请求业务组件添加
    2. tooltip组件添加

    1.1.1

    1. apmSelect添加
    2. NetworkReqTreeView开放toggle以及select接口

    1.1.2

    1. apmSelect文档修改
    2. networkReqTreeView
      • 属性命名更通用
      • 毫秒外部传递
      • 修复toggle/select bug
      • 支持service内部异步加载

    1.1.3

    1. reqTreeView 若干修改
      • select和toggle参数接口约定变更
      • select和toggle新增事件发送开关配置
    2. reqPanel面板相关功能添加
      • 点击确认收缩面板
      • 收缩后点x想外部触发事件
      • 新增selected用于是否选中

    1.1.4

    1. 依照视觉稿添加apmSelect样式
    2. apm雪碧图添加及在线demo

    Keywords

    Install

    npm i apm-ui

    DownloadsWeekly Downloads

    7

    Version

    1.1.4

    License

    MIT

    Last publish

    Collaborators

    • wangdong5