Nondeterministic Polynomial Munchies
    Have ideas to improve npm?Join in the discussion! »

    @worker-tools/event-target-polyfill

    0.1.2 • Public • Published

    Event Target Polyfill

    A polyfill for EventTarget (and Event), meant to run in Cloudflare Workers (also works in older version of node or possibly IE 11) that has the most accurate set of characteristics of EventTarget that can be provided.

    Usage

    import '@worker-tools/event-target-polyfill';
    
    const et = new EventTarget();
    
    et.addEventListener('test', () => console.log('hit!'));
    
    et.dispatchEvent(new Event('test'));

    Development

    This library has no dependencies. Even development dependencies. To test just run npm test. It runs a script, and if it finishes without error, the tests pass.

    Install

    npm i @worker-tools/event-target-polyfill

    DownloadsWeekly Downloads

    0

    Version

    0.1.2

    License

    MIT

    Unpacked Size

    12.5 kB

    Total Files

    6

    Last publish

    Collaborators

    • avatar