Neatly Positioned Magazines
    Have ideas to improve npm?Join in the discussion! »

    @pulumi/eks
    TypeScript icon, indicating that this package has built-in type declarations

    0.31.0 • Public • Published

    Build Status Slack NPM version Python version NuGet version PkgGoDev

    Pulumi Amazon Web Services (AWS) EKS Components

    The Pulumi EKS library provides a Pulumi component that creates and manages the resources necessary to run an EKS Kubernetes cluster in AWS.

    This includes:

    • The EKS cluster control plane.
    • The cluster's worker nodes configured as node groups, which are managed by an auto scaling group.
    • The AWS CNI Plugin aws-k8s-cni to manage pod networking in Kubernetes.

    Pre-Requisites

    1. Install Pulumi.
    2. Install kubectl.

    Installing

    To use from JavaScript or TypeScript in Node.js, install it using either npm:

    $ npm install @pulumi/eks

    or yarn:

    $ yarn add @pulumi/eks

    Python

    To use from Python, install using pip:

    $ pip install pulumi_eks
    

    Go

    To use from Go, use go get to grab the latest version of the library

    $ go get github.com/pulumi/pulumi-eks/sdk/go
    

    .NET

    To use from .NET, install using dotnet add package:

    $ dotnet add package Pulumi.Eks
    

    References

    Contributing

    If you are interested in contributing, please see the contributing docs.

    Code of Conduct

    You can read the code of conduct here.

    Keywords

    Install

    npm i @pulumi/eks

    DownloadsWeekly Downloads

    5,208

    Version

    0.31.0

    License

    Apache-2.0

    Unpacked Size

    259 kB

    Total Files

    61

    Homepage

    pulumi.com

    Last publish

    Collaborators

    • avatar
    • avatar