Have ideas to improve npm?Join in the discussion! »

    @opt/nopt

    0.1.1 • Public • Published

    @opt/nopt

    Build Status Dependency Status npm version Coverage Status

    Plugin for @opt/parse making nopt the parser.

    See @opt/parse

    See @opt/nopt

    See @use/core

    Install

    npm install @opt/nopt --save

    Usage

    var parse = require('@opt/parse')
     
    // choose the internal parser as `nopt`
    parse.use('@opt/nopt')
     
    // optionally add other plugins by package name:
    parse.use('@opt/words', '@opt/require')
     
    // then use parse as you would use `nopt`,
    // plus any changes made possible by the plugins added
    options = parse({}, {}, process.argv, 2)

    MIT License

    Install

    npm i @opt/nopt

    DownloadsWeekly Downloads

    0

    Version

    0.1.1

    License

    MIT

    Last publish

    Collaborators

    • avatar
    • avatar