Have ideas to improve npm?Join in the discussion! »

    @newsteam/eslint-config
    TypeScript icon, indicating that this package has built-in type declarations

    0.0.47 • Public • Published

    @newsteam/eslint-config

    License npm package npm downloads Dependencies DevDependencies

    This package provides a shared config for eslint and several of its plugins.

    Optionally, it also includes support for eslinting typescript.

    Usage

    A single ESLint configuration is exported.

    Our default export contains all of our ESLint rules, including ECMAScript 6+ and several plugins. It requires the following peer dependencies:

        @typescript-eslint/eslint-plugin
        @typescript-eslint/parser
        eslint
        eslint-plugin-array-func
        eslint-plugin-async-await
        eslint-plugin-compat
        eslint-plugin-css-modules
        eslint-plugin-es
        eslint-plugin-eslint-comments
        eslint-plugin-filenames
        eslint-plugin-format-message
        eslint-plugin-import
        eslint-plugin-jsx-control-statements
        eslint-plugin-lean-imports
        eslint-plugin-more
        eslint-plugin-no-unsanitized
        eslint-plugin-no-useless-assign
        eslint-plugin-node
        eslint-plugin-optimize-regex
        eslint-plugin-prefer-object-spread
        eslint-plugin-promise
        eslint-plugin-react
        eslint-plugin-react-filenames
        eslint-plugin-react-hooks
        eslint-plugin-react-native
        eslint-plugin-react-perf
        eslint-plugin-react-redux
        eslint-plugin-react-ssr
        eslint-plugin-security
        eslint-plugin-sort-keys-fix
        eslint-plugin-unicorn
        eslint-plugin-webassembly
        eslint-plugin-you-dont-need-lodash-underscore
        eslint-plugin-you-dont-need-momentjs
        typescript
    

    Installation

    1. Install the shared configuration:
    npm install --save-dev @newsteam/eslint-config
    1. Install the shared configuration peer dependencies (npm 5+):
    npx install-peerdeps --dev @newsteam/eslint-config
    1. Add this to your .eslintrc.
      "extends": "@newsteam"

    Maintenance

    You can run tests with npm test.

    You can make sure this module lints with itself using npm run lint.

    Install

    npm i @newsteam/eslint-config

    DownloadsWeekly Downloads

    112

    Version

    0.0.47

    License

    MIT

    Unpacked Size

    184 kB

    Total Files

    205

    Last publish

    Collaborators

    • avatar