Neat Paraskavedekatriaphobia's Meaning
    Have ideas to improve npm?Join in the discussion! »

    @meotimdihia/postgres

    1.0.17 • Public • Published

    @keyv/postgres keyv

    PostgreSQL storage adapter for Keyv

    Build Status Coverage Status npm

    PostgreSQL storage adapter for Keyv.

    Requires Postgres 9.5 or newer for ON CONFLICT support to allow performant upserts. Why?

    Install

    npm install --save keyv @keyv/postgres

    Usage

    const Keyv = require('keyv');
    
    const keyv = new Keyv('postgresql://user:pass@localhost:5432/dbname');
    keyv.on('error', handleConnectionError);

    You can specify the table option.

    e.g:

    const keyv = new Keyv('postgresql://user:pass@localhost:5432/dbname', { table: 'cache' });

    License

    MIT © Luke Childs

    Install

    npm i @meotimdihia/postgres

    DownloadsWeekly Downloads

    20

    Version

    1.0.17

    License

    MIT

    Unpacked Size

    4.86 kB

    Total Files

    6

    Last publish

    Collaborators

    • avatar