Have ideas to improve npm?Join in the discussion! »

    @elliottcable/bs-uchar

    0.0.4 • Public • Published

    bs-uchar

    This is the Uchar compatibility library from OCaml 4.03, backported to OCaml 4.02, and thus BuckleScript (an OCaml-to-JavaScript compiler, forked from OCaml 4.02.3) and Reason (an alternative OCaml syntax targeting that compiler.)

    You can safely ignore the installation instructions below when compiling to JS. Instead:

    1. Install this fork through npm:

       npm install --save @elliottcable/bs-uchar
      
    2. Manually add bs-uchar to your bsconfig.json's bs-dependencies:

       "bs-dependencies": [
         ...
         "@elliottcable/bs-uchar"
       ],
      
    3. Use Uchar.t!

    Original README follows:

    Uchar — Compatibility library for OCaml's Uchar module

    Release %%VERSION%%

    The uchar package provides a compatibility library for the Uchar module introduced in OCaml 4.03.

    The uchar package is distributed under the license of the OCaml compiler. See LICENSE for details.

    Home page: https://ocaml.github.io/uchar/
    Contact: Daniel Bünzli <daniel.buenzl i@erratique.ch>

    Installation

    Uchar can be installed with opam:

    opam install uchar
    

    If you don't use opam consult the opam file for build instructions.

    Documentation

    Since OCaml 4.03 you can find the module in the documentation of the standard library. Before this you can consult this page.

    Testing

    The file test/testpkg.ml can be used to test the compilation of the package. Once the package is installed the following invocation should succeed both before and after 4.03

    ocamlbuild -X src -use-ocamlfind -pkg uchar test/testpkg.native
    

    Install

    npm i @elliottcable/bs-uchar

    DownloadsWeekly Downloads

    24

    Version

    0.0.4

    License

    SEE LICENSE IN ./LICENSE

    Unpacked Size

    38.2 kB

    Total Files

    8

    Last publish

    Collaborators

    • avatar