Need private packages and team management tools?Check out npm Teams »

@beaker/datignore

1.0.0 • Public • Published

@beaker/datignore

A module for reading and using .datignore files.

const datignore = require('@beaker/datignore')
const anymatch = require('anymatch')
 
// convert a .datignore to rules that can be fed into anymatch()
const rules = datignore.toAnymatchRules(`
  .git
  .dat
  node_modules
  *.log
`)
anymatch(rules, ...)

Keywords

Install

npm i @beaker/datignore

DownloadsWeekly Downloads

89

Version

1.0.0

License

MIT

Unpacked Size

3.37 kB

Total Files

4

Last publish

Collaborators

  • avatar
  • avatar
  • avatar