Neverending Pile of Messages
    Wondering what’s next for npm?Check out our public roadmap! »

    This package has been deprecated

    Author message:

    This component is no longer developed and used in API Console

    @api-components/raml-aware
    TypeScript icon, indicating that this package has built-in type declarations

    3.0.0 • Public • Published

    Build Status

    Published on webcomponents.org

    raml-aware

    <raml-aware> Element that is aware of the AMF (RAML, OAS) content.

    <h3>Basic authorization</h3>
    <raml-aware raml='{"scope": "request"}' scope="request"></raml-aware>
    <raml-aware raml='{"scope": "import"}' scope="import"></raml-aware>
     
    <raml-aware id="a1" scope="request"></raml-aware>
    <raml-aware id="a2" scope="import"></raml-aware>
    <output id="o1"></output>
    <script>
    o1.innerText = JSON.stringify(a1.raml) + '<br/>';
    o1.innerText += JSON.stringify(a2.raml);
    </script> 

    API components

    This components is a part of API components ecosystem: https://elements.advancedrestclient.com/

    Keywords

    Install

    npm i @api-components/raml-aware

    DownloadsWeekly Downloads

    604

    Version

    3.0.0

    License

    Apache-2.0

    Unpacked Size

    23.2 kB

    Total Files

    6

    Last publish

    Collaborators

    • avatar
    • avatar
    • avatar
    • avatar